aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 19:42:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:25:47 +0200
commit5cc79c9c5049540c701fe532a2953b4da2c470bb (patch)
treecc9b403e57de23126609690ba6b39cf6b79ccf43
parent2856369fad5d841aa1d46c359e67dc16aeba5657 (diff)
downloadguix-5cc79c9c5049540c701fe532a2953b4da2c470bb.tar
guix-5cc79c9c5049540c701fe532a2953b4da2c470bb.tar.gz
gnu: Add r-powerlaw.
* gnu/packages/cran.scm (r-powerlaw): New variable.
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0fc158768d..83f246d4d0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -263,3 +263,28 @@ the powerful computational and visual environment in R, it gives users more
convenience and freedom to design figures for better understanding complex
patterns behind multiple dimensional data.")
(license license:gpl2+)))
+
+(define-public r-powerlaw
+ (package
+ (name "r-powerlaw")
+ (version "0.70.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "poweRlaw" version))
+ (sha256
+ (base32
+ "1p2la3hslxq2xa8jkwvci6zcpn47cvyr9xqd5agp1riwwp2xw5gh"))))
+ (properties `((upstream-name . "poweRlaw")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-vgam" ,r-vgam)))
+ (home-page "https://github.com/csgillespie/poweRlaw")
+ (synopsis "Tools for the analysis of heavy tailed distributions")
+ (description
+ "This package provides an implementation of maximum likelihood estimators
+for a variety of heavy tailed distributions, including both the discrete and
+continuous power law distributions. Additionally, a goodness-of-fit based
+approach is used to estimate the lower cut-off for the scaling region.")
+ ;; Any of these GPL versions.
+ (license (list license:gpl2 license:gpl3))))