aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-02-01 03:00:06 -0500
committerLeo Famulari <leo@famulari.name>2021-02-01 03:02:49 -0500
commit263b3961f40e49078a25e4118d1c8efc70e8d03f (patch)
treee6975edaf390cf9d6d54f303f4099e17212eb40b
parent26a66d0feaab7626c4053071d5557394931fe14b (diff)
downloadguix-263b3961f40e49078a25e4118d1c8efc70e8d03f.tar
guix-263b3961f40e49078a25e4118d1c8efc70e8d03f.tar.gz
Revert "gnu: kwayland: Enable test suite."
This reverts commit ba3e25bbf217637d2054bb0c8b906f3eed230613. This commit is reverted because it caused kwayland to no longer build on the build farm. Specifically, the test "PlasmaWindowModelTest::testVirtualDesktops" fails. See this discussion for more information: https://lists.gnu.org/archive/html/guix-devel/2021-01/msg00382.html
-rw-r--r--gnu/packages/kde-frameworks.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 8c2028b978..9ecbf75d34 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016-2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
@@ -1047,12 +1047,13 @@ integration with a custom editor as well as a ready-to-use
("wayland" ,wayland)
("wayland-protocols" ,wayland-protocols)))
(arguments
- `(#:phases
+ `(#:tests? #f ; FIXME tests require weston to run
+ ; weston requires wayland flags in mesa
+ #:phases
(modify-phases %standard-phases
(add-before 'check 'check-setup
(lambda _
(setenv "XDG_RUNTIME_DIR" "/tmp")
- (setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Qt-style API to interact with the wayland client and server")