aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-06-06 07:12:20 +0100
committerChristopher Baines <mail@cbaines.net>2017-09-13 18:19:29 +0100
commit31d3a7c729068681a3a05036a3fe993213635fc6 (patch)
treed620a16847c510960f151489a97b633cb68f5e02
parent921bb359ba0112faf16f40ad5f10745beceb96f2 (diff)
downloadguix-31d3a7c729068681a3a05036a3fe993213635fc6.tar
guix-31d3a7c729068681a3a05036a3fe993213635fc6.tar.gz
gnu: Add discount.
This is required by perl-text-markdown-discount, which is required by ikiwiki. * gnu/packages/markdown.scm (discount) New variable.
-rw-r--r--gnu/packages/markup.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 121e6cdbf4..e3630fe2f4 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -102,6 +102,48 @@ convert it to structurally valid XHTML (or HTML).")
(license (non-copyleft "file://License.text"
"See License.text in the distribution."))))
+(define-public discount
+ (package
+ (name "discount")
+ (version "2.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.pell.portland.or.us/~orc/Code/"
+ name "/" name "-" version ".tar.bz2"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0r4gjyk1ngx47zhb25q0gkjm3bz2m5x8ngrk6rim3y1y3rricygc"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:make-flags (list
+ (string-append "LFLAGS=-L. -Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'set-AC_PATH
+ (lambda _
+ ;; The default value is not suitable, so override using an
+ ;; environment variable. This just affects the build, and not the
+ ;; resulting store item.
+ (setenv "AC_PATH" (getenv "PATH"))
+ #t))
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (setenv "CC" "gcc")
+ (zero? (system*
+ "./configure.sh"
+ (string-append "--prefix=" (assoc-ref outputs "out"))
+ "--shared")))))))
+ (synopsis "Markdown processing library, written in C")
+ (description
+ "Discount is a markdown implementation, written in C. It provides a
+@command{markdown} command, and a library.")
+ (home-page "http://www.pell.portland.or.us/~orc/Code/discount/")
+ (license bsd-3)))
+
(define-public cmark
(package
(name "cmark")