aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2017-10-13 14:04:57 -0400
committerLudovic Courtès <ludo@gnu.org>2017-10-14 17:07:36 +0200
commitd02c287390ead5d2b2e6c963b6cb513345b588b2 (patch)
treea588b50e0b45d4ea68425479bf6f071a7e897f6e
parent7aafb3b324055fab42fa28fe527f86966e85de8e (diff)
downloadguix-d02c287390ead5d2b2e6c963b6cb513345b588b2.tar
guix-d02c287390ead5d2b2e6c963b6cb513345b588b2.tar.gz
gnu: Add emacs-easy-kill.
* gnu/packages/emacs.scm (emacs-easy-kill): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 66f0a2ebed..8e2a40345a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -5995,3 +5995,22 @@ an elisp expression.")
"@code{bash-completion} defines dynamic completion hooks for shell-mode
and shell-command prompts that are based on bash completion.")
(license license:gpl2+)))
+
+(define-public emacs-easy-kill
+ (package
+ (name "emacs-easy-kill")
+ (version "0.9.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/easy-kill-"
+ version ".tar"))
+ (sha256
+ (base32
+ "17nw0mglmg877axwg1d0gs03yc0p04lzmd3pl0nsnqbh3303fnqb"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/leoliu/easy-kill")
+ (synopsis "Kill and mark things easily in Emacs")
+ (description
+ "This package provides commands @code{easy-kill} and @code{easy-mark} to
+let users kill or mark things easily.")
+ (license license:gpl3+)))