aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-06 10:58:08 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-06 10:58:08 +0200
commitf34ccd506e6594ad253f3f8d1c03171e7520a4b9 (patch)
treef55d51e9bd5219bacb9033193ebc3bed0230c08c
parente085a53a2ed8e37eb89c7ff86b0393039a5a8896 (diff)
downloadguix-f34ccd506e6594ad253f3f8d1c03171e7520a4b9.tar
guix-f34ccd506e6594ad253f3f8d1c03171e7520a4b9.tar.gz
gnu: toot: Update to 0.30.1.
* gnu/packages/mastodon.scm (toot): Update to 0.30.1. [arguments]: Add a phase to remove integration tests.
-rw-r--r--gnu/packages/mastodon.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index d6fd1db2b6..e8c31fb168 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Taiju HIGASHI <higashi@taiju.info>
;;;
@@ -42,17 +42,22 @@
(define-public toot
(package
(name "toot")
- (version "0.28.0")
+ (version "0.30.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "toot" version))
(sha256
- (base32 "1wsj4160z3m1nvswgkl08n9ymihxhxdvxvrsycn9d3y5fplm00k9"))))
+ (base32 "0r9f2frlwfxkcv6c9lh36maph90v2yp6s7phynbrb3m7v35xzaxz"))))
(build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-before 'check 'adjust-test-suite
+ (lambda _
+ ;; This test contains integration tests meant to run against a test
+ ;; Mastodon instance.
+ (delete-file "tests/test_integration.py")))
(replace 'check
(lambda* (#:key tests? inputs outputs #:allow-other-keys)
(when tests?