aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-06 11:09:39 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-06 11:09:39 +0200
commited18b697c4783f139e23731f5bd0b0ed197997bb (patch)
treeec1ba89c4688bf2079a2cce44202ff2d59e91869
parentf34ccd506e6594ad253f3f8d1c03171e7520a4b9 (diff)
downloadguix-ed18b697c4783f139e23731f5bd0b0ed197997bb.tar
guix-ed18b697c4783f139e23731f5bd0b0ed197997bb.tar.gz
gnu: Add python-aiostream.
* gnu/packages/python-web.scm (python-aiostream): New variable.
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4f3a587c6a..72e20a130f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -513,6 +513,35 @@ comes with a SOCKS proxy client.")
(base32
"1rswrspv27x33xa5bnhrkjqzhv0sknv5kd7pl1vidw9d2z4rx2l0"))))))
+(define-public python-aiostream
+ (package
+ (name "python-aiostream")
+ (version "0.4.5")
+ (source (origin
+ ;; Tests not included in pypi release.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vxgmichel/aiostream")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l2ijb7yk0820wiyf6zrzx8fhzf8925an7r06mcaw3in1mr6rssq"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-pytest
+ python-pytest-asyncio
+ python-pytest-cov
+ python-pytest-runner))
+ (home-page "https://github.com/vxgmichel/aiostream")
+ (synopsis "Generator-based operators for asynchronous iteration")
+ (description "@code{aiostream} provides a collection of stream operators that can
+be combined to create asynchronous pipelines of operations. It can be seen as an
+asynchronous version of @code{itertools}, although some aspects are slightly
+different. All the provided operators return a unified interface called a stream. A
+stream is an enhanced asynchronous iterable.")
+ (license license:gpl3)))
+
(define-public python-asgiref
(package
(name "python-asgiref")