aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2022-10-11 15:10:00 +0200
committerChristopher Baines <mail@cbaines.net>2022-12-06 11:14:50 +0000
commitdb1c357a788fe38de033ef4f7ad4497d72557898 (patch)
tree9615c46c265841549ca95ec10f049757076f2db2
parent3d2c9608abb8ee2d9e427611673d042ccfd2fbe0 (diff)
downloadguix-db1c357a788fe38de033ef4f7ad4497d72557898.tar
guix-db1c357a788fe38de033ef4f7ad4497d72557898.tar.gz
gnu: Add python-simple-rlp.
* gnu/packages/python-xyz.scm (python-simple-rlp): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b74b120510..b0202853d8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3011,6 +3011,29 @@ the optional C extension for speedups. Simplejson is also supported on
Python 3.3+.")
(license license:x11)))
+(define-public python-simple-rlp
+ (package
+ (name "python-simple-rlp")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SamuelHaidu/simple-rlp")
+ ;; Upstream doesn't tag the git repo.
+ (commit "342ea269d84da1ddc4a7630cdebc90159261391c")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nv92sphpkyrncak4qgj50qmgkmj4ycl2szbnv9c7ihgl5df4div"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/SamuelHaidu/simple-rlp")
+ (synopsis
+ "Python implementation of RLP (Recursive Length Prefix) encoding")
+ (description
+ "@code{simple-rlp} is a python implementation of RLP (Recursive Length \
+Prefix) - Encode and decode data structures.")
+ (license license:expat)))
(define-public python-pyicu
(package