aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-06 10:43:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-06 10:43:41 +0200
commit5b3623e6fdc66c736a3bf6f2f2c6c90a9958abc5 (patch)
treee0cb579756e59514cbe382e49beec2490198aaf1
parent47f28e5536f124f331e39243c771a91fcce0ed9a (diff)
downloadguix-5b3623e6fdc66c736a3bf6f2f2c6c90a9958abc5.tar
guix-5b3623e6fdc66c736a3bf6f2f2c6c90a9958abc5.tar.gz
gnu: Add pod2pdf.
* gnu/packages/documentation.scm (pod2pdf): New variable.
-rw-r--r--gnu/packages/documentation.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 585a295fb4..3ded8e1cac 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -36,6 +36,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
#:use-module (guix deprecation)
@@ -262,6 +263,32 @@ browsing. The documentation is extracted directly from the C/C++/IDL source
or Java class files.")
(license gpl2+)))
+(define-public pod2pdf
+ (package
+ (name "pod2pdf")
+ (version "0.42")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JO/JONALLEN/pod2pdf-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0w5p7yy01vph74nfr9qzjb18p1avmhhcpza0qz9r88fmb0blbiyv"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ (list perl-getopt-argvfile
+ perl-pdf-api2
+ perl-pod-parser))
+ (home-page "https://metacpan.org/release/pod2pdf")
+ (synopsis "Convert Pod to PDF format")
+ (description "pod2pdf converts documents written in Perl's @acronym{POD, Plain Old
+Documentation} format to PDF files. It also supports some extensions to the POD
+format, and supports the file types JPG, GIF, TIFF, PNG, and PNM for embedded
+objects.")
+ (license artistic2.0)))
+
(define-public python-docrepr
(package
(name "python-docrepr")