aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-06 10:43:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-06 10:43:05 +0200
commit47f28e5536f124f331e39243c771a91fcce0ed9a (patch)
tree733d57bbdffcaf15b1559df44ccdcac57397f6f8
parent41a904c8b366bbe79fa4bef530ea4edd67e4de60 (diff)
downloadguix-47f28e5536f124f331e39243c771a91fcce0ed9a.tar
guix-47f28e5536f124f331e39243c771a91fcce0ed9a.tar.gz
gnu: Add perl-getopt-argvfile.
* gnu/packages/perl.scm (perl-getopt-argvfile): New variable.
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 0e21176751..26d20e4593 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5206,6 +5206,27 @@ Linux, fsevents on OS X, @code{kqueue} on FreeBSD, and
back to a full directory scan if none of these are available.")
(license license:perl-license)))
+(define-public perl-getopt-argvfile
+ (package
+ (name "perl-getopt-argvfile")
+ (version "1.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JS/JSTENZEL/Getopt-ArgvFile-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "08jvhfqcjlsn013x96qa6paif0095x6y60jslp8p3zg67i8sl29p"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Getopt-ArgvFile")
+ (synopsis "Perl module for reading script options and parameters from files")
+ (description "This module simply interpolates option file hints in @code{@@ARGV}
+by the contents of the pointed files. This enables option reading from files instead
+of or additional to the usual reading from the command line.")
+ (license license:artistic2.0)))
+
(define-public perl-getopt-long
(package
(name "perl-getopt-long")