aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2022-10-11 15:12:42 +0200
committerChristopher Baines <mail@cbaines.net>2022-12-06 11:14:53 +0000
commit346469e04eeca68634e8b6cce7bb1f953aaef226 (patch)
tree0dd21ad3eee57d4c708f297077c6f1a8dedc01c9
parentdb1c357a788fe38de033ef4f7ad4497d72557898 (diff)
downloadguix-346469e04eeca68634e8b6cce7bb1f953aaef226.tar
guix-346469e04eeca68634e8b6cce7bb1f953aaef226.tar.gz
gnu: Add python-bech32.
* gnu/packages/finance.scm (python-bech32): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/finance.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index eb70503f57..cc2d417003 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -889,6 +889,23 @@ the Monero command line client and daemon.")
the Monero GUI client.")
(license license:bsd-3)))
+(define-public python-bech32
+ (package
+ (name "python-bech32")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "bech32" version))
+ (sha256
+ (base32
+ "16fq5cfy5id9hp123ylhpl55pf38xwk0hv7sziqpig838qhvhvbx"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/fiatjaf/bech32")
+ (synopsis "Reference implementation for Bech32 and Segwit addresses")
+ (description "This package provides a python reference implementation for
+Bech32 and segwit addresses.")
+ (license license:expat)))
+
(define-public python-trezor-agent
;; It is called 'libagent' in pypi; i.e. this is the library as opposed to
;; the toplevel app called trezor-agent.