aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDemis Balbach <db@minikn.xyz>2022-11-28 23:17:58 +0100
committerLudovic Courtès <ludo@gnu.org>2022-12-05 22:22:20 +0100
commit248b40cd2d0aec1224352fb13f746f4546979edd (patch)
tree073b2d3f826e99be62f51f68187763a8bb79ea26
parentf70e0dd6d8ace2f5bae85dc311b563e240bc009d (diff)
downloadguix-248b40cd2d0aec1224352fb13f746f4546979edd.tar
guix-248b40cd2d0aec1224352fb13f746f4546979edd.tar.gz
gnu: Add tuxedo-keyboard.
* gnu/packages/linux.scm (tuxedo-keyboard): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 50cf227ea0..49e90a9ba6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -68,6 +68,7 @@
;;; Copyright © 2022 Hunter Jozwiak <hunter.t.joz@gmail.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2022 Stefan <stefan-guix@vodafonemail.de>
+;;; Copyright © 2022 Demis Balbach <db@minikn.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1531,6 +1532,33 @@ battery charging thresholds, keyboard backlight, fans and thermal monitors,
and the notification, WiFi, and Bluetooth LED.")
(license license:gpl2)))
+(define-public tuxedo-keyboard
+ (package
+ (name "tuxedo-keyboard")
+ (version "3.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tuxedocomputers/tuxedo-keyboard.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17n14yh55yrxx4qbx4ph9drbzx2ll4kdsfmlngrdgizhyzk7z7zv"))))
+ (build-system linux-module-build-system)
+ (arguments
+ (list #:tests? #f)) ; no test suite
+ (home-page "https://github.com/tuxedocomputers/tuxedo-keyboard")
+ (synopsis "Linux kernel modules to control keyboard on most Tuxedo computers")
+ (description
+ "This package provides the @code{tuxedo_keyboard}, @code{tuxedo_io},
+@code{clevo_wmi} @acronym{WMI, Windows Management Engine} and the
+@code{clevo_acpi} @acronym{ACPI, Advanced Configuration and Power Interface}
+kernel modules to control the keyboard on most Tuxedo computers. Only white
+backlight only models are currently not supported. The @code{tuxedo_io} module
+is also needed for the @code{tuxedo-control-center} (short tcc) package.")
+ (license license:gpl3+)))
+
(define-public ec
(package
(name "ec")