aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-04-07 14:33:44 +0200
committerChristopher Baines <mail@cbaines.net>2024-04-17 17:55:53 +0100
commit77acd4b4aaecea72a7b5249f602eac8bea67880b (patch)
treed840a6842a531a4b2de927d5212ddd8edb3bd398
parente1fefe84aa73d6d48ab43f7c613c7bc6d14d082f (diff)
downloadguix-77acd4b4aaecea72a7b5249f602eac8bea67880b.tar
guix-77acd4b4aaecea72a7b5249f602eac8bea67880b.tar.gz
gnu: evolution-data-server: Disable failing test on aarch64.
This test is flaky on an Apple M1. * gnu/packages/gnome.scm (evolution-data-server): Disable failing test on aarch64. Change-Id: Iccb75f2144b773a8b94242aaee9e6acedaa3af0b Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 787cf66f09..489f23865b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8222,6 +8222,14 @@ Microsoft Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
"-DWITH_PHONENUMBER=ON"))
#:phases
#~(modify-phases %standard-phases
+ #$@(if (target-aarch64?)
+ #~((add-after 'unpack 'disable-failing-aarch64-tests
+ (lambda _
+ ;; 26/90 Test #26: test-book-client-custom-summary
+ ;; ...........SIGTRAP***Exception: 35.99 sec
+ (substitute* "tests/libebook/client/CMakeLists.txt"
+ (("test-book-client-custom-summary") "")))))
+ '())
(add-after 'unpack 'disable-failing-tests
(lambda _
;; tests/book-migration/test-migration.c:160:test_fetch_contacts: