aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-04-10 10:52:14 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2024-04-10 10:52:14 -0400
commit2718616f77aace28b3962fef29b4e38b87a512ce (patch)
treef9eb61eb6cd7a6812f1b8d528d2b46dbb52e82c5
parent6cae1db889f62051580d5a365f62585412a53a8c (diff)
downloadguix-2718616f77aace28b3962fef29b4e38b87a512ce.tar
guix-2718616f77aace28b3962fef29b4e38b87a512ce.tar.gz
gnu: openexr: Fix build.
Two issues are fixed with this commit. First, openexr would fail to build on i686-linux due to a test which checks for SSE2. Secondly, dependents could fail to find openexr as it now has libdeflate in the Requires.private of OpenEXR.pc. * gnu/packages/graphics.scm (openexr)[arguments]: Enable SSE2 for x86_64-linux and i686-linux in configure-flags. [inputs]: Remove zlib (no longer used). Move libdeflate from here ... [propagated-inputs]: ... to here. Change-Id: Ib2e6669036033e262447ba4b1b98c20c7db13bf1
-rw-r--r--gnu/packages/graphics.scm21
1 files changed, 17 insertions, 4 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ec1d7c9569..a5e36d6513 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -28,7 +28,7 @@
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022, 2023, 2024 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2022 Tobias Kortkamp <tobias.kortkamp@gmail.com>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
@@ -142,7 +142,8 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix deprecation)
- #:use-module (guix utils))
+ #:use-module (guix utils)
+ #:use-module (ice-9 match))
(define-public mmm
(package
@@ -1204,7 +1205,16 @@ graphics.")
"00s1a05kggk71vfbnsvykyjc2j7y6yyzgl63sy4yiddshz2k2mcr"))))
(build-system cmake-build-system)
(arguments
- (list #:phases
+ (list #:configure-flags
+ #~(list #$@(match (%current-system)
+ ;; A test explicitly checks for SSE2 (would fail on
+ ;; i686-linux), so make sure it is enabled for both C
+ ;; and CPP.
+ ((or "x86_64-linux" "i686-linux")
+ '("-DCMAKE_CXX_FLAGS=-mfpmath=sse -msse2"
+ "-DCMAKE_C_FLAGS=-mfpmath=sse -msse2"))
+ (_ '())))
+ #:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-test-directory
(lambda _
@@ -1236,7 +1246,10 @@ graphics.")
"")
(("TEST \\(testOptimizedInterleavePatterns, \"basic\"\\);")
"")))))))))
- (inputs (list imath libdeflate zlib))
+ (inputs (list imath))
+ (propagated-inputs
+ ;; Marked as Requires.private in OpenEXR.pc.
+ (list libdeflate))
(home-page "https://www.openexr.com/")
(synopsis "High-dynamic-range file format library")
(description