aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2023-02-15 11:44:10 -0500
committerLudovic Courtès <ludo@gnu.org>2023-02-27 23:40:43 +0100
commitfb9124cb049061b2a51589420dd528962972b04b (patch)
treeca64aff3880365376be9549518ba0c06b1f2de31
parent064d3310689754a8846a6e67cb27e6d985232f70 (diff)
downloadguix-fb9124cb049061b2a51589420dd528962972b04b.tar
guix-fb9124cb049061b2a51589420dd528962972b04b.tar.gz
gnu: leptonica: Use new package style.
* gnu/packages/image.scm (leptonica)[inputs]: Remove labels. [arguments]<#:phases>: Use gexps; use "this-package-input" to locate package input; do not explicitly return #t from phases. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/image.scm50
1 files changed, 24 insertions, 26 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 5071dd588f..8212407cc1 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -619,33 +619,31 @@ collection of tools for doing simple manipulations of TIFF images.")
libtool
pkg-config))
(inputs
- `(("giflib" ,giflib)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("libwebp" ,libwebp)
- ("openjpeg" ,openjpeg)
- ("zlib" ,zlib)))
+ (list giflib
+ libjpeg-turbo
+ libpng
+ libtiff
+ libwebp
+ openjpeg
+ zlib))
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-reg-wrapper
- (lambda _
- (substitute* "prog/reg_wrapper.sh"
- ((" /bin/sh ")
- (string-append " " (which "sh") " "))
- (("which gnuplot")
- "true"))
- #t))
- (add-after 'install 'provide-absolute-giflib-reference
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (giflib (assoc-ref inputs "giflib")))
- ;; Add an absolute reference to giflib to avoid propagation.
- (with-directory-excursion (string-append out "/lib")
- (substitute* '("liblept.la" "pkgconfig/lept.pc")
- (("-lgif") (string-append "-L" giflib "/lib -lgif"))))
- #t))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-reg-wrapper
+ (lambda _
+ (substitute* "prog/reg_wrapper.sh"
+ ((" /bin/sh ")
+ (string-append " " (which "sh") " "))
+ (("which gnuplot")
+ "true"))))
+ (add-after 'install 'provide-absolute-giflib-reference
+ (lambda _
+ (let ((giflib #$(this-package-input "giflib")))
+ ;; Add an absolute reference to giflib to avoid propagation.
+ (with-directory-excursion (string-append #$output "/lib")
+ (substitute* '("liblept.la" "pkgconfig/lept.pc")
+ (("-lgif") (string-append "-L" giflib "/lib -lgif"))))))))))
(home-page "http://www.leptonica.com/")
(synopsis "Library and tools for image processing and analysis")
(description