aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2023-02-13 16:01:12 -0500
committerLudovic Courtès <ludo@gnu.org>2023-02-27 15:54:10 +0100
commitcf9e0508b26196dc985302776d860a0359652c59 (patch)
tree5f65a4fac180972f5dd2ed7573ddbfa70592753b
parentbe8714b07af70d9bc72f9798970627d0a696ce94 (diff)
downloadguix-cf9e0508b26196dc985302776d860a0359652c59.tar
guix-cf9e0508b26196dc985302776d860a0359652c59.tar.gz
gnu: hwloc: Skip failing test on non-x86 systems.
* gnu/packages/mpi.scm (hwloc-2)[arguments]<#:phases>: Rename "skip-test-that-requires-/sys" phase to "skip-tests-that-require-/sys" and expand to skip additional test requiring /sys on non-x86 systems. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/mpi.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index b318acd4b9..baef62616f 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -165,10 +165,19 @@ bind processes, and much more.")
(substitute* "tests/hwloc/linux-libnuma.c"
(("numa_available\\(\\)")
"-1"))))
- (add-before 'check 'skip-test-that-requires-/sys
+ (add-before 'check 'skip-tests-that-require-/sys
(lambda _
;; 'test-gather-topology.sh' requires /sys as of 2.9.0; skip it.
- (setenv "HWLOC_TEST_GATHER_TOPOLOGY" "0")))
+ (setenv "HWLOC_TEST_GATHER_TOPOLOGY" "0")
+
+ ;; 'hwloc_backends' also requires /sys on non-x86 systems, for
+ ;; which hwloc lacks a topology backend not reliant on the
+ ;; operating system; skip it also on these machines.
+ (substitute* "tests/hwloc/hwloc_backends.c"
+ ,@(if (not (target-x86?))
+ '((("putenv\\(\\(char \\*\\) \"HWLOC_L" all)
+ (string-append "exit (77);\n" all)))
+ '()))))
(add-before 'check 'skip-test-that-fails-on-qemu
(lambda _
;; Skip test that fails on emulated hardware due to QEMU bug: