aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-01-25 09:27:32 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-02-26 10:26:14 +0100
commit9ce5ec5397ae29220326516b348243ee085bc40d (patch)
tree1b0d25b71172d522d2afa88d1df40e1c1fd2382f
parentd603946d38a7b62cf1bb2616285b61cca8d169e9 (diff)
downloadguix-9ce5ec5397ae29220326516b348243ee085bc40d.tar
guix-9ce5ec5397ae29220326516b348243ee085bc40d.tar.gz
gnu: Remove unused Haskell packages.
* gnu/packages/haskell-xyz.scm (ghc-attoparsec-bootstrap): Remove variable. (ghc-integer-logarithms-bootstrap): Likewise. (ghc-scientific-bootstrap): Likewise. (ghc-wcwidth-bootstrap): Likewise. (ghc-optparse-applicative-0.15.1.0): Likewise.
-rw-r--r--gnu/packages/haskell-xyz.scm59
1 files changed, 0 insertions, 59 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 69ff954ce4..1ecb377ffc 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -581,16 +581,6 @@ aimed particularly at dealing efficiently with network protocols and
complicated text/binary file formats.")
(license license:bsd-3)))
-(define-public ghc-attoparsec-bootstrap
- (package
- (inherit ghc-attoparsec)
- (name "ghc-attoparsec-bootstrap")
- (arguments `(#:tests? #f))
- (inputs
- `(("ghc-scientific" ,ghc-scientific-bootstrap)))
- (native-inputs '())
- (properties '((hidden? #t)))))
-
(define-public ghc-attoparsec-iso8601
(package
(name "ghc-attoparsec-iso8601")
@@ -5825,14 +5815,6 @@ minimal overhead. No FFI required.")
in migrated modules.")
(license license:expat)))
-(define-public ghc-integer-logarithms-bootstrap
- (package
- (inherit ghc-integer-logarithms)
- (name "ghc-integer-logarithms-bootstrap")
- (arguments `(#:tests? #f))
- (native-inputs '())
- (properties '((hidden? #t)))))
-
(define-public ghc-interpolate
(package
(name "ghc-interpolate")
@@ -8052,27 +8034,6 @@ easily work with command-line options.")
command line options in Haskell.")
(license license:bsd-3)))
-(define-public ghc-optparse-applicative-0.15.1.0
- (package
- (inherit ghc-optparse-applicative)
- (name "ghc-optparse-applicative")
- (version "0.15.1.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/optparse-applicative/optparse-applicative-"
- version
- ".tar.gz"))
- (sha256
- (base32 "1ws6y3b3f6hsgv0ff0yp6lw4hba1rps4dnvry3yllng0s5gngcsd"))))
- (inputs
- (list ghc-transformers-compat ghc-ansi-wl-pprint))
- (native-inputs (list ghc-quickcheck))
- (arguments
- `(#:cabal-revision
- ("1" "0zmhqkd96v2z1ilhqdkd9z4jgsnsxb8yi2479ind8m5zm9363zr9")))))
-
(define-public ghc-jira-wiki-markup
(package
(name "ghc-jira-wiki-markup")
@@ -10179,18 +10140,6 @@ and space efficient. They are represented using
notation}.")
(license license:bsd-3)))
-(define-public ghc-scientific-bootstrap
- (package
- (inherit ghc-scientific)
- (name "ghc-scientific-bootstrap")
- (arguments `(#:tests? #f))
- (inputs
- `(("ghc-integer-logarithms" ,ghc-integer-logarithms-bootstrap)
- ("ghc-hashable" ,ghc-hashable)
- ("ghc-primitive" ,ghc-primitive)))
- (native-inputs '())
- (properties '((hidden? #t)))))
-
(define-public ghc-sdl
(package
(name "ghc-sdl")
@@ -13424,14 +13373,6 @@ The command line tool can compile a width table to Haskell code that assigns
widths to the Char type.")
(license license:bsd-3)))
-(define-public ghc-wcwidth-bootstrap
- (package
- (inherit ghc-wcwidth)
- (name "ghc-wcwidth-bootstrap")
- (inputs
- (list ghc-setlocale ghc-utf8-string ghc-attoparsec-bootstrap))
- (properties '((hidden? #t)))))
-
(define-public ghc-weigh
(package
(name "ghc-weigh")