aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-02-24 22:23:46 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2023-02-27 13:41:32 +0100
commit945edb86543d06fb7809d9c0c405a60ea03e7556 (patch)
treea85a3d7bddb5af4080203020f7ee50e7bede8ef3
parent4ca869d151637382e8c74908e6d2671d9cea805c (diff)
downloadguix-945edb86543d06fb7809d9c0c405a60ea03e7556.tar
guix-945edb86543d06fb7809d9c0c405a60ea03e7556.tar.gz
gnu: cl-sdl2: Remove input labels.
* gnu/packages/lisp.scm (sbcl-sdl2): [arguments]{asd-systems}: Add sdl2/examples. {phases}<fix-path>: Remove trailing #f from lambda, use search-input-file to link SO library. [inputs]: Remove labels, add sbcl-cl-opengl. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 648141b19b..4772be6cef 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20138,21 +20138,22 @@ except system libraries.")
(base32 "0sjy4k04k0hdhwpr57ns16ag3za0kz4laclbk17i91ql7qdjw9z2"))))
(build-system asdf-build-system/sbcl)
(arguments
- `(#:phases
+ `(#:asd-systems '("sdl2" "sdl2/examples")
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/library.lisp"
- (("libSDL2-2.0.so.0" all)
- (string-append (assoc-ref inputs "libsdl2") "/lib/" all)))
- #t)))))
+ (("libSDL2-2.0.so.0")
+ (search-input-file inputs "/lib/libSDL2-2.0.so.0"))))))))
(inputs
- `(("alexandria" ,sbcl-alexandria)
- ("cl-autowrap" ,sbcl-cl-autowrap)
- ("cl-ppcre" ,sbcl-cl-ppcre)
- ("libsdl2" ,sdl2)
- ("trivial-channels" ,sbcl-trivial-channels)
- ("trivial-features" ,sbcl-trivial-features)))
+ (list sbcl-alexandria
+ sbcl-cl-autowrap
+ sbcl-cl-opengl
+ sbcl-cl-ppcre
+ sbcl-trivial-channels
+ sbcl-trivial-features
+ sdl2))
(home-page "https://github.com/lispgames/cl-sdl2")
(synopsis "Common Lisp bindings for SDL2 using C2FFI")
(description