aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-01-29 18:58:45 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-02-26 10:26:15 +0100
commit8a4ee0c113d33be376afd701d6cd1b94821f2cd2 (patch)
tree83e5fc84249e40a83948d8a45ad0f8a4f431e4c5
parent7df12c8ca631cc46f59da9ceeb883a28044dbb9e (diff)
downloadguix-8a4ee0c113d33be376afd701d6cd1b94821f2cd2.tar
guix-8a4ee0c113d33be376afd701d6cd1b94821f2cd2.tar.gz
gnu: ghc-lua: Disable symbol export.
This turns on the linker flag -Wl,-E for all libraries depending on it, resulting in large binaries, because --gc-sections cannot clean exported symbols. * gnu/packages/haskell-xyz.scm (ghc-lua)[arguments]: Disable export-dynamic feature.
-rw-r--r--gnu/packages/haskell-xyz.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 475db5c275..b4a327b2cc 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15454,6 +15454,9 @@ embeddable scripting language <https://lua.org Lua>.")
"07wni3ji46ndqabwffgwzij2jk34dq2d66z15hcd6jg33sqnym45"))))
(build-system haskell-build-system)
(properties '((upstream-name . "lua")))
+ (arguments
+ ;; Allow creating fully static binaries. Avoids issues with linking pandoc statically.
+ `(#:configure-flags (list "-f-export-dynamic")))
(native-inputs (list ghc-tasty ghc-tasty-hunit))
(home-page "https://hslua.org/")
(synopsis "Lua, an embeddable scripting language")