aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-27 16:46:06 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-27 16:46:06 +0100
commit6b6e05cd23fba4d9c6191b0713019faf870c3516 (patch)
treec3e0070704ea00aa0e08e00f0a695e5456937d86
parentc21a2aa1f7f1e291906881c71888b62eeed2faec (diff)
downloadguix-6b6e05cd23fba4d9c6191b0713019faf870c3516.tar
guix-6b6e05cd23fba4d9c6191b0713019faf870c3516.tar.gz
gnu: Add sugar-typing-turtle-activity.
* gnu/packages/sugar.scm (sugar-typing-turtle-activity): New variable.
-rw-r--r--gnu/packages/sugar.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/sugar.scm b/gnu/packages/sugar.scm
index fbc8da4206..de5b304497 100644
--- a/gnu/packages/sugar.scm
+++ b/gnu/packages/sugar.scm
@@ -384,3 +384,41 @@ the Sugar Toolkit.")
(description "This is an activity for the Sugar environment which aims
to provide users with easy access to documentation and manuals.")
(license license:gpl3+))))
+
+(define-public sugar-typing-turtle-activity
+ (package
+ (name "sugar-typing-turtle-activity")
+ (version "32")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sugarlabs/typing-turtle-activity")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0shadv9wgddjvl97kvsqb8iw1wmmfw5lzcqk78hd70pzvh4c1hmd"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:test-target "check"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-launcher
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "activity/activity.info"
+ (("exec = sugar-activity3")
+ (string-append "exec = "
+ (search-input-file inputs "/bin/sugar-activity3"))))))
+ (replace 'install
+ (lambda _
+ (invoke "python" "setup.py" "install"
+ (string-append "--prefix=" #$output)))))))
+ (native-inputs
+ (list gettext-minimal sugar-toolkit-gtk3))
+ (home-page "https://help.sugarlabs.org/en/typing_turtle.html")
+ (synopsis "Learn typing")
+ (description "Need some help typing? In this activity for the Sugar
+environment you will learn the best way to hold your hands in order for you to
+become a faster typist.")
+ (license license:gpl3+)))