aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2023-02-28 06:27:52 +0400
committerAndrew Tropin <andrew@trop.in>2023-02-28 06:35:14 +0400
commit60e03bb5e75be35440fb64a626d3e71918dc465c (patch)
tree9705a27a3450f09dd6cd16e883f9b5790bcf8665
parentff5fbcc19bce6e94ead0cc79b27ae8ed0307463d (diff)
downloadguix-60e03bb5e75be35440fb64a626d3e71918dc465c.tar
guix-60e03bb5e75be35440fb64a626d3e71918dc465c.tar.gz
gnu: emacs-corfu: Generate info from README.org.
* gnu/packages/emacs-xyz.scm (emacs-corfu)[native-inputs]: Add texinfo. [arguments]: Migrate to gexps, generate info from README.org.
-rw-r--r--gnu/packages/emacs-xyz.scm31
1 files changed, 21 insertions, 10 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cd4a36beda..35399fce38 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3798,16 +3798,27 @@ of bibliographic references.")
(base32 "1xqg796844wk6kvn3xw4bqlxn9ra6jlwk7rsc5gy4j77l0gwl441"))))
(build-system emacs-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Move the extensions source files to the top level, which is included
- ;; in the EMACSLOADPATH.
- (add-after 'unpack 'move-source-files
- (lambda _
- (let ((el-files (find-files "./extensions" ".*\\.el$")))
- (for-each (lambda (f)
- (rename-file f (basename f)))
- el-files)))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Move the extensions source files to the top level, which is included
+ ;; in the EMACSLOADPATH.
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./extensions" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ el-files))))
+ (add-after 'install 'makeinfo
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "emacs"
+ "--batch"
+ "--eval=(require 'ox-texinfo)"
+ "--eval=(find-file \"README.org\")"
+ "--eval=(org-texinfo-export-to-info)")
+ (install-file "corfu.info"
+ (string-append #$output "/share/info")))))))
+ (native-inputs (list texinfo))
(propagated-inputs
(list emacs-compat))
(home-page "https://github.com/minad/corfu")