aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-01-29 18:54:15 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-02-26 10:26:16 +0100
commit503998ac7ae16bf5587c69db18e70abdd2f14565 (patch)
treef61ae265caed0c520cd96b3d3ec9c5e8c655ef23
parentbaf9e0a33685eea208132f374df6756dc2aaf89c (diff)
downloadguix-503998ac7ae16bf5587c69db18e70abdd2f14565.tar
guix-503998ac7ae16bf5587c69db18e70abdd2f14565.tar.gz
gnu: hledger: Drop Haskell libraries and documentation.
* gnu/packages/finance.scm (ghc-hledger): New variable. (hledger): Inherit from ghc-hledger and add 'remove-libraries phase and disable #:haddock?.
-rw-r--r--gnu/packages/finance.scm48
1 files changed, 31 insertions, 17 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 192d1d2817..d2da017091 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -214,9 +214,9 @@ line client and a client based on Qt.")
(define-public bitcoin-core bitcoin-core-23.0)
-(define-public hledger
+(define-public ghc-hledger
(package
- (name "hledger")
+ (name "ghc-hledger")
(version "1.27.1")
(source (origin
(method url-fetch)
@@ -225,14 +225,6 @@ line client and a client based on Qt.")
(base32
"0qdg87m7ys2ykqqq32p7h7aw827w4f5bcqx4dspxxq6zqlvzddqb"))))
(build-system haskell-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'install-doc
- (lambda _
- (install-file "hledger.info" (string-append #$output "/share/info"))
- (install-file "hledger.1" (string-append #$output "/man/man1")))))))
(properties '((upstream-name . "hledger")))
(inputs (list ghc-decimal
ghc-diff
@@ -275,6 +267,23 @@ rewrite of Ledger, and one of the leading implementations of Plain Text
Accounting.")
(license license:gpl3)))
+(define-public hledger
+ (package
+ (inherit ghc-hledger)
+ (name "hledger")
+ (arguments
+ (list
+ #:haddock? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda _
+ (install-file "hledger.info" (string-append #$output "/share/info"))
+ (install-file "hledger.1" (string-append #$output "/man/man1"))))
+ (add-after 'register 'remove-libraries
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively (string-append (assoc-ref outputs "out") "/lib")))))))))
+
(define-public homebank
(package
(name "homebank")
@@ -1991,7 +2000,7 @@ generate a variety of reports from them, and provides a web interface.")
ghc-data-default
ghc-extra
ghc-hjsmin
- hledger
+ ghc-hledger
ghc-hledger-lib
ghc-hspec
ghc-http-client
@@ -2015,12 +2024,17 @@ generate a variety of reports from them, and provides a web interface.")
ghc-yesod-static
ghc-yesod-test))
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- ;; Tests write to $HOME.
- (add-before 'check 'set-home
- (lambda _
- (setenv "HOME" "/tmp"))))))
+ (list
+ #:haddock? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Tests write to $HOME.
+ (add-before 'check 'set-home
+ (lambda _
+ (setenv "HOME" "/tmp")))
+ (add-after 'register 'remove-libraries
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively (string-append (assoc-ref outputs "out") "/lib")))))))
(home-page "http://hledger.org")
(synopsis "Web-based user interface for the hledger accounting system")
(description