aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-02-28 09:28:58 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-02-28 09:29:43 +0100
commit3bb2078a12d78a13f1e1520fe3705333a74ef6e3 (patch)
tree9bd5cfb777600bc7be29905c585d1cbd33145a7e
parenta79950af1568c262a79fc0cdfd391b7328c058cf (diff)
downloadguix-3bb2078a12d78a13f1e1520fe3705333a74ef6e3.tar
guix-3bb2078a12d78a13f1e1520fe3705333a74ef6e3.tar.gz
gnu: ghc-9.2: Increase max-silent-time.
Times out on i686 CI, but not locally. * gnu/packages/haskell.scm (ghc-9.2)[properties]: Add max-silent-time.
-rw-r--r--gnu/packages/haskell.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 16f4e2d530..dddc85459a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1309,6 +1309,7 @@ interactive environment for the functional language Haskell.")
;; Increase verbosity, so running the test suite does not time out on CI.
((#:make-flags make-flags ''())
#~(cons "VERBOSE=4" #$make-flags))))
+ (properties '((max-silent-time . 36000))) ; 10 hours, for i686.
(native-inputs
`(;; GHC 9.2 must be built with GHC >= 8.6.
("ghc-bootstrap" ,base)