aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThanos Apollo <public@thanosapollo.com>2023-08-14 12:38:19 +0300
committerLudovic Courtès <ludo@gnu.org>2023-09-11 23:12:25 +0200
commitd514b7b4adf9aef198e5aedecffaf6f7014c0044 (patch)
treec4b6a58acb62bf0386504e44174e4d32d352f9d3
parent3f76970fda82057f12429f81c41a47d8d8c3b954 (diff)
downloadguix-d514b7b4adf9aef198e5aedecffaf6f7014c0044.tar
guix-d514b7b4adf9aef198e5aedecffaf6f7014c0044.tar.gz
gnu: Add emacs-yeetube.
* gnu/packages/emacs-xyz.scm (emacs-yeetube): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e971edb676..355afbf8fb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -134,6 +134,7 @@
;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
+;;; Copyright © 2023 Thanos Apollo <public@thanosapollo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27896,6 +27897,33 @@ as playing them in some video player, or downloading them.")
and comments.")
(license license:gpl3+))))
+(define-public emacs-yeetube
+ (package
+ (name "emacs-yeetube")
+ (version "1.4.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~thanosapollo/yeetube.el")
+ (commit version)))
+ (sha256
+ (base32
+ "0vfap6sri6qnswrjsp6qvmrp98bvrfh58gwdqbjiakq1fzvcrm03"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (inputs
+ (list mpv yt-dlp))
+ (home-page "https://sr.ht/~thanosapollo/yeetube.el")
+ (synopsis "Youtube & Invidious front-end for Emacs")
+ (description
+ "This package offers an Emacs interface that allows you to search YouTube
+or an Invidious instance for a specific query. The search results are shown as
+links in an org-mode buffer. The videos can be opened to a user-defined video
+player(by default mpv) or downloaded using yt-dlp. This package also includes
+a yt-dlp front-end.")
+ (license license:gpl3+)))
+
(define-public emacs-org-web-tools
(package
(name "emacs-org-web-tools")