aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-08 12:24:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-08 12:25:22 +0300
commitd4645d5d25c9de0def9745c48a96504e500ec850 (patch)
treefdb2dfde3002e178f6ca2b76b14415f9b7147c06
parent68132407da0105ea7598e903f54b5096792ca17c (diff)
downloadguix-d4645d5d25c9de0def9745c48a96504e500ec850.tar
guix-d4645d5d25c9de0def9745c48a96504e500ec850.tar.gz
gnu: python-fasteners: Update to 0.17.3.
* gnu/packages/python-xyz.scm (python-fasteners): Update to 0.17.3. [build-system]: Switch to pyproject-build-system. [arguments]: Add custom 'check phase. [propagated-inputs]: Remove python-monotonic and python-six. [native-inputs]: Remove python-testtools; add python-diskcache, python-more-itertools, and python-pytest.
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 19 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 408c370adf..a3b7b9fa60 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24763,19 +24763,25 @@ and corruption checks.")
(define-public python-fasteners
(package
(name "python-fasteners")
- (version "0.15")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "fasteners" version))
- (sha256
- (base32
- "1vzmz1xh38b84dv0f4hlp7arwmx8wjlih6lf964bpy8dnyk6s5rs"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-monotonic python-six))
- (native-inputs
- (list python-testtools))
+ (version "0.17.3")
+ (source (origin
+ ;; No tests in the pypi tarball
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/harlowja/fasteners")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0m0dxv8ljpkq99s3d1mib1zfb0ppx3h74h5yr8809zsrq2klfn0m"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (native-inputs (list python-diskcache python-more-itertools python-pytest))
(home-page "https://github.com/harlowja/fasteners")
(synopsis "Python package that provides useful locks")
(description