aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-08 09:38:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-08 12:25:19 +0300
commit9144a7809a697ce57079f6f488648976d5e9c788 (patch)
tree7e38e6bd41f51a14f3100da8de19d1a019686c8f
parent3eb77954f969df41c000e7018a6b598b9f562d8d (diff)
downloadguix-9144a7809a697ce57079f6f488648976d5e9c788.tar
guix-9144a7809a697ce57079f6f488648976d5e9c788.tar.gz
gnu: python-eventlet: Update to 0.33.3.
* gnu/packages/python-xyz.scm (python-eventlet): Update to 0.33.3. [propagated-inputs]: Remove python-monotonic. [arguments]: Skip another test.
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index aeaaeb4059..979cbd4b56 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3486,17 +3486,17 @@ standard.")
(define-public python-eventlet
(package
(name "python-eventlet")
- (version "0.33.0")
+ (version "0.33.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "eventlet" version))
(sha256
(base32
- "07qlyhcm0f28sxdizawvdf3d50m3hnbzz5kg3fjp7chvki44y540"))))
+ "1nngffz21afhfi266smf4s5mn5dfd0ykdnirfls9bwnzxbkh6a3j"))))
(build-system python-build-system)
(propagated-inputs
- (list python-dnspython python-greenlet python-monotonic python-six))
+ (list python-dnspython python-greenlet python-six))
(native-inputs
(list python-nose))
(arguments
@@ -3521,7 +3521,9 @@ standard.")
;; <https://github.com/eventlet/eventlet/issues/730>.
"-e" "test_patcher_existing_locks_locked"
;; And see <https://github.com/eventlet/eventlet/issues/739>.
- "-e" "test_017_ssl_zeroreturnerror")))))))
+ "-e" "test_017_ssl_zeroreturnerror"
+ ;; This test is failing on some architectures
+ "-e" "test_fork_after_monkey_patch")))))))
(home-page "https://eventlet.net")
(synopsis "Concurrent networking library for Python")
(description