aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-08 12:15:38 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-08 12:25:22 +0300
commit68132407da0105ea7598e903f54b5096792ca17c (patch)
tree9362e80c9292b850d4a7da58f0423ae10d762c26
parent420d51fa02d5eeea441f8b9bc0395cf0bb68a2fb (diff)
downloadguix-68132407da0105ea7598e903f54b5096792ca17c.tar
guix-68132407da0105ea7598e903f54b5096792ca17c.tar.gz
gnu: python-numcodecs: Fix building on non x86 machines.
* gnu/packages/python-xyz.scm (python-numcodecs)[source]: Adjust snippet to prevent setup.py adding unsupported architecture specific CFLAGS.
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 32fa9500e9..408c370adf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25143,6 +25143,13 @@ tool).")
(modules '((guix build utils)))
(snippet
'(begin
+ ;; Only add CFLAGS on architectures where they are supported
+ (substitute* "setup.py"
+ (("import sys")
+ "import sys\nimport platform")
+ (("os\\.name == 'posix'")
+ (string-append "os.name + platform.machine() == 'posixx86_64' or"
+ " os.name + platform.machine() == 'posixx86'")))
(delete-file-recursively "c-blosc")
(for-each delete-file '("numcodecs/_shuffle.c"
"numcodecs/blosc.c"