aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-08 10:01:02 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-08 12:25:21 +0300
commit67ffb90dcbc88694fea4a1cbfc01c49aec4d1808 (patch)
treef5514ffe5b4b1b6588469b44c6a840980fbb295d
parent7525396c1ea205f70d3e095f51e50f1d80827bff (diff)
downloadguix-67ffb90dcbc88694fea4a1cbfc01c49aec4d1808.tar
guix-67ffb90dcbc88694fea4a1cbfc01c49aec4d1808.tar.gz
gnu: Remove python-pyflakes-2.2.
* gnu/packages/python-xyz.scm (python-pyflakes-2.2): Delete variable. * gnu/packages/patches/python-pyflakes-test-location.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-pyflakes-test-location.patch42
-rw-r--r--gnu/packages/python-xyz.scm13
3 files changed, 0 insertions, 56 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index f58d04cf91..2b20606ca1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1835,7 +1835,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-piexif-fix-tests-with-pillow-7.2.patch \
%D%/packages/patches/python-pillow-CVE-2022-45199.patch \
%D%/packages/patches/python-pyfakefs-remove-bad-test.patch \
- %D%/packages/patches/python-pyflakes-test-location.patch \
%D%/packages/patches/python-flint-includes.patch \
%D%/packages/patches/python-libxml2-utf8.patch \
%D%/packages/patches/python-memcached-syntax-warnings.patch \
diff --git a/gnu/packages/patches/python-pyflakes-test-location.patch b/gnu/packages/patches/python-pyflakes-test-location.patch
deleted file mode 100644
index ea2c50c82e..0000000000
--- a/gnu/packages/patches/python-pyflakes-test-location.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-This patch fixes test failure related to reported source code locations.
-It is a backport of this patch:
-
- commit 6a5f38b5ab12260fde8a0463acd433bc2d34dbcf
- Author: Louis Sautier <sautier.louis@gmail.com>
- Date: Sat Oct 3 02:37:53 2020 +0200
-
- Fix tests with Python 3.9, closes #549 (#586)
-
- Stop allowing failures on Python nightly.
-
-diff --git a/pyflakes/test/test_api.py b/pyflakes/test/test_api.py
-index 128aa69..b728e65 100644
---- a/pyflakes/test/test_api.py
-+++ b/pyflakes/test/test_api.py
-@@ -515,6 +515,8 @@ def foo(bar=baz, bax):
- if ERROR_HAS_LAST_LINE:
- if PYPY and sys.version_info >= (3,):
- column = 7
-+ elif sys.version_info >= (3, 9):
-+ column = 21
- elif sys.version_info >= (3, 8):
- column = 9
- else:
-@@ -543,6 +545,8 @@ foo(bar=baz, bax)
- if ERROR_HAS_LAST_LINE:
- if PYPY and sys.version_info >= (3,):
- column = 12
-+ elif sys.version_info >= (3, 9):
-+ column = 17
- elif sys.version_info >= (3, 8):
- column = 14
- else:
-@@ -577,6 +581,8 @@ foo(bar=baz, bax)
- position_end = 1
- if PYPY:
- column = 6
-+ elif ver >= (3, 9):
-+ column = 13
- else:
- column = 7
- # Column has been "fixed" since 3.2.4 and 3.3.1
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 325ff8b822..a540c6367d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12493,19 +12493,6 @@ file (e.g. @file{PKG-INFO}).")
"Pyflakes statically checks Python source code for common errors.")
(license license:expat)))
-(define-public python-pyflakes-2.2
- (package
- (inherit python-pyflakes)
- (version "2.2.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "pyflakes" version))
- (sha256
- (base32
- "1j3zqbiwkyicvww499bblq33x0bjpzdrxajhaysr7sk7x5gdgcim"))
- (patches
- (search-patches "python-pyflakes-test-location.patch"))))))
-
(define-public python-mccabe
(package
(name "python-mccabe")