aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Dion <olivier.dion@polymtl.ca>2023-09-07 11:20:52 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-09 19:03:37 -0400
commit610752ac1ae8cef027c0c0afcef3e73b7747ef49 (patch)
tree70cc2438555457d0e3637837b36355d33ec58a39
parent5db78e7c1b06d1b4892bdb3e153b95b21577271e (diff)
downloadguix-610752ac1ae8cef027c0c0afcef3e73b7747ef49.tar
guix-610752ac1ae8cef027c0c0afcef3e73b7747ef49.tar.gz
gnu: multipath-tools: Update to 0.9.6.
* gnu/packages/linux.scm (multipath-tools): Update to 0.9.6. [#:make-flags]: Set systemd_prefix to output and remove SYSTEMDPATH. [#:phases]: Add phase 'no-fortfify-3 before 'build. [inputs]: Add util-linux "lib" output for libmount. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/linux.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 67edc98013..b1bcda5e70 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5548,7 +5548,7 @@ arrays when needed.")
(define-public multipath-tools
(package
(name "multipath-tools")
- (version "0.9.3")
+ (version "0.9.6")
(home-page "https://github.com/opensvc/multipath-tools")
(source (origin
(method git-fetch)
@@ -5556,7 +5556,7 @@ arrays when needed.")
(file-name (git-file-name name version))
(sha256
(base32
- "0zcnr1135znizbnfqhqv3by9i2qwn5vg6kgmj6ma3yy1x1krx0d4"))
+ "1933iqh9r54pdl95yck0n4bw7jiiblymc964vlc1787qd4q012sz"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -5574,7 +5574,7 @@ arrays when needed.")
(string-append "prefix=" #$output)
;; Install Udev rules below this directory, relative
;; to the prefix.
- "SYSTEMDPATH=lib")
+ (string-append "systemd_prefix=" #$output))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -5606,6 +5606,16 @@ arrays when needed.")
(("CFLAGS \\+= " match)
(string-append match "-Wno-error=unused-function ")))))
(delete 'configure) ;no configure script
+ (add-before 'build 'no-fortify-3
+ (lambda _
+ ;; NOTE: The check made seems to wrongly assume the
+ ;; FORTIFY_SOURCE=3 is valid. However, when compiling, warnings
+ ;; are emitted from glibc, resulting in failed build. Fix this
+ ;; by forcing the usage of FORTIFY_SOURCE=2.
+ (substitute* "create-config.mk"
+ (("FORTIFY_SOURCE=3")
+ "FORTIFY_SOURCE=2"))
+ ))
(add-before 'build 'set-LDFLAGS
(lambda _
;; Note: this cannot be passed as a make flag because that will
@@ -5623,7 +5633,9 @@ arrays when needed.")
liburcu
lvm2
readline
- eudev))
+ eudev
+ ;; For libmount.
+ `(,util-linux "lib")))
(synopsis "Access block devices through multiple paths")
(description
"This package provides the following binaries to drive the