aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Natali <me@fabionatali.com>2023-08-13 16:16:15 +0100
committerLudovic Courtès <ludo@gnu.org>2023-09-11 23:30:03 +0200
commit251bf55f507860d9775b520585c0fdd7ede7d534 (patch)
treedfc775b580143278fa9c6837eff232382c5e690c
parentd514b7b4adf9aef198e5aedecffaf6f7014c0044 (diff)
downloadguix-251bf55f507860d9775b520585c0fdd7ede7d534.tar
guix-251bf55f507860d9775b520585c0fdd7ede7d534.tar.gz
gnu: Add emacs-notmuch-indicator.
* gnu/packages/emacs-xyz.scm (emacs-notmuch-indicator): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 355afbf8fb..4a4aa85dbc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30302,6 +30302,27 @@ displays as you type thanks to Helm, though @command{notmuch-search} does the
real search.")
(license license:gpl3+)))
+(define-public emacs-notmuch-indicator
+ (package
+ (name "emacs-notmuch-indicator")
+ (version "1.0.1")
+ (home-page "https://git.sr.ht/~protesilaos/notmuch-indicator")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/notmuch-indicator-" version
+ ".tar"))
+ (sha256
+ (base32
+ "1n5k2ikk93mdwqqysf6l7gd8i6iazk8yvbqpf8xnz5zny248cc2x"))))
+ (build-system emacs-build-system)
+ (synopsis "Display a mode line indicator with @code{notmuch-count} output")
+ (description "This package renders an indicator with an email count of the
+@code{notmuch} index on the Emacs mode line. The underlying mechanism is that of
+@code{notmuch-count}, which is used to find the number of items that match the
+given search terms.")
+ (license license:gpl3+)))
+
(define-public emacs-notmuch-maildir
(package
(name "emacs-notmuch-maildir")