aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDistopico <distopico@riseup.net>2023-09-05 19:46:56 -0500
committerAndrew Tropin <andrew@trop.in>2023-09-07 16:25:59 +0400
commit20832dac483b779beb80a145c6f14d4860dbde7f (patch)
treeff349f6ce573242d4a812746b5dee9a53bc61d49
parent5ef28595e9dff8b88ec3fcb4d887fbc380c9a8b8 (diff)
downloadguix-20832dac483b779beb80a145c6f14d4860dbde7f.tar
guix-20832dac483b779beb80a145c6f14d4860dbde7f.tar.gz
gnu: Add emacs-flymake-guile.
* gnu/packages/emacs-xyz.scm (emacs-flymake-guile): New variable. Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 55a2ffa53c..ee893f020a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -133,6 +133,7 @@
;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
+;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2537,6 +2538,29 @@ and help selectively enable or disable diagnostic functions based on major
modes.")
(license license:expat)))
+(define-public emacs-flymake-guile
+ (package
+ (name "emacs-flymake-guile")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://framagit.org/flymake-backends/flymake-guile.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cb2wcn34bzj93y7s1g2b2sxv79vqihb3a5n0rhxbrddfila95hh"))))
+ (build-system emacs-build-system)
+ (home-page "https://framagit.org/flymake-backends/flymake-guile")
+ (synopsis "GNU Guile support for Flymake")
+ (description
+ "This package provides a Flymake backend for GNU Guile using @code{guild
+compile}.")
+ (license license:gpl3+)))
+
(define-public emacs-flymake-popon
(package
(name "emacs-flymake-popon")