summaryrefslogtreecommitdiff
path: root/gnu/packages/grub.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/grub.scm')
-rw-r--r--gnu/packages/grub.scm25
1 files changed, 17 insertions, 8 deletions
diff --git a/gnu/packages/grub.scm b/gnu/packages/grub.scm
index 31b270c0d8..01f2a8454d 100644
--- a/gnu/packages/grub.scm
+++ b/gnu/packages/grub.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -76,20 +77,21 @@
(define-public grub
(package
(name "grub")
- (version "2.00")
+ (version "2.02beta3")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://gnu/grub/grub-"
- version ".tar.xz"))
+ (uri (string-append
+ "ftp://alpha.gnu.org/gnu/grub/grub-"
+ "2.02~beta3"
+ ".tar.xz"))
+ (file-name (string-append name "-" version ".tar.xz"))
(sha256
(base32
- "0n64hpmsccvicagvr0c6v0kgp2yw0kgnd3jvsyd26cnwgs7c6kkq"))
- (patches (search-patches "grub-gets-undeclared.patch"
- "grub-freetype.patch"
- "grub-CVE-2015-8370.patch"))))
+ "18ddwnw0vxs7zigvah0g6a5z5vvlz0p8fjglxv1h59sjbrakvv1h"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-werror")
+ '(;; Two warnings: suggest braces, signed/unsigned comparison.
+ #:configure-flags '("--disable-werror")
#:phases (modify-phases %standard-phases
(add-after
'unpack 'patch-stuff
@@ -100,6 +102,13 @@
;; Make the font visible.
(copy-file (assoc-ref inputs "unifont") "unifont.bdf.gz")
(system* "gunzip" "unifont.bdf.gz")
+
+ ;; We hit an assertion failure in
+ ;; grub-core/tests/video_checksum.c, as reported at
+ ;; <https://lists.gnu.org/archive/html/grub-devel/2016-07/msg00026.html>.
+ ;; Disable this test for now.
+ (substitute* "tests/grub_func_test.in"
+ (("set -e") "exit 77\nset -e"))
#t)))))
(inputs
`(;; ("lvm2" ,lvm2)