summaryrefslogtreecommitdiff
path: root/gnu/packages/cinnamon.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cinnamon.scm')
-rw-r--r--gnu/packages/cinnamon.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/cinnamon.scm b/gnu/packages/cinnamon.scm
index 65aea47d5a..7cac863f92 100644
--- a/gnu/packages/cinnamon.scm
+++ b/gnu/packages/cinnamon.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,13 +51,10 @@
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'autoconf
+ (add-before 'bootstrap 'skip-premature-configure
(lambda _
- (mkdir-p "m4")
- (zero?
- (and (system* "glib-gettextize" "--force" "--copy")
- (system* "intltoolize" "--force" "--copy" "--automake")
- (system* "autoreconf" "--verbose" "--force" "--install"))))))))
+ (setenv "NOCONFIGURE" "set")
+ #t)))))
;; TODO: package 'libgsystem'.
(inputs
`(("accountsservice" ,accountsservice)