summaryrefslogtreecommitdiff
path: root/gnu/tests
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-08-02 05:32:56 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-08-16 02:46:27 +0530
commitde30205ba0f63eb987097a9f47b6e4fd38cd9044 (patch)
treeccf6ee940595361d42e382a9ebd6c0a72c4f385d /gnu/tests
parent3480d6f7219da1970d6e9a8da243274432524220 (diff)
downloadgnu-guix-de30205ba0f63eb987097a9f47b6e4fd38cd9044.tar
gnu-guix-de30205ba0f63eb987097a9f47b6e4fd38cd9044.tar.gz
gnu: services: Add pcscd service.
* gnu/services/security-token.scm: New file. * gnu/tests/security-token.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Register new files. * doc/guix.texi (Miscellaneous Services): Document the service.
Diffstat (limited to 'gnu/tests')
-rw-r--r--gnu/tests/security-token.scm71
1 files changed, 71 insertions, 0 deletions
diff --git a/gnu/tests/security-token.scm b/gnu/tests/security-token.scm
new file mode 100644
index 0000000000..1169a4b9fd
--- /dev/null
+++ b/gnu/tests/security-token.scm
@@ -0,0 +1,71 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu tests security-token)
+ #:use-module (gnu tests)
+ #:use-module (gnu system vm)
+ #:use-module (gnu services)
+ #:use-module (gnu services security-token)
+ #:use-module (guix gexp)
+ #:export (%test-pcscd))
+
+(define %pcscd-os
+ (simple-operating-system
+ (service pcscd-service-type)))
+
+(define* (run-pcscd-test)
+ "Run tests of 'pcscd-service-type'."
+ (define os
+ (marionette-operating-system
+ %pcscd-os
+ #:imported-modules '((gnu services herd))
+ #:requirements '(pcscd)))
+
+ (define test
+ (with-imported-modules '((gnu build marionette))
+ #~(begin
+ (use-modules (srfi srfi-64)
+ (gnu build marionette))
+ (define marionette
+ (make-marionette (list #$(virtual-machine os))))
+
+ (mkdir #$output)
+ (chdir #$output)
+
+ (test-begin "pcscd")
+
+ (test-assert "pcscd is alive"
+ (marionette-eval
+ '(begin
+ (use-modules (gnu services herd))
+ (live-service-running
+ (find (lambda (live)
+ (memq 'pcscd (live-service-provision live)))
+ (current-services))))
+ marionette))
+
+ (test-end)
+ (exit (= (test-runner-fail-count (test-runner-current)) 0)))))
+
+ (gexp->derivation "pcscd" test))
+
+(define %test-pcscd
+ (system-test
+ (name "pcscd")
+ (description "Test a running pcscd daemon.")
+ (value (run-pcscd-test))))