summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-09-22 20:15:12 +0100
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2017-09-23 20:17:07 +0100
commitf666aaf757dcf600e4a3c03d40754940a657af98 (patch)
tree0337aecf575c5f009726f62bf283a368906e7898
parent78ae416d0f3cfe199ef217f549619a01f4ffb00a (diff)
downloadgnu-guix-f666aaf757dcf600e4a3c03d40754940a657af98.tar
gnu-guix-f666aaf757dcf600e4a3c03d40754940a657af98.tar.gz
gnu: Add ruby-options.
* gnu/packages/ruby.scm (ruby-options): New variable.
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 116db8c624..1ee03e0665 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -660,6 +660,34 @@ complexity.")
(home-page "https://github.com/ThoughtWorksStudios/saikuro_treemap")
(license license:expat)))
+(define-public ruby-options
+ (package
+ (name "ruby-options")
+ (version "2.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "options" version))
+ (sha256
+ (base32
+ "1s650nwnabx66w584m1cyw82icyym6hv5kzfsbp38cinkr5klh9j"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f ;; TODO: NameError: uninitialized constant Config
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-LIB
+ (lambda _
+ ;; This is used in the Rakefile, and setting it avoids an issue
+ ;; with running the tests.
+ (setenv "LIB" "options"))))))
+ (synopsis "Ruby library to parse options from *args cleanly")
+ (description
+ "The @code{options} library helps with parsing keyword options in Ruby
+functions.")
+ (home-page "https://github.com/ahoward/options")
+ (license license:ruby)))
+
(define-public ruby-orderedhash
(package
(name "ruby-orderedhash")