summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-02-27 19:02:55 +0000
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-05-30 18:18:19 +0100
commitf4fa449794f575e500a02f044e4d8ccb10c0c1a1 (patch)
tree7723f3edf0841e2748eeca774cc5dea9765aeb7e
parent8b49bc5f55e4db916b5590620bb81a6ab3d4fc34 (diff)
downloadgnu-guix-f4fa449794f575e500a02f044e4d8ccb10c0c1a1.tar
gnu-guix-f4fa449794f575e500a02f044e4d8ccb10c0c1a1.tar.gz
gnu: Add ruby-fugit.
* gnu/packages/ruby.scm (ruby-fugit): New variable.
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6b460ad336..155bb39247 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1830,6 +1830,30 @@ standard output stream.")
(home-page "https://github.com/geemus/formatador")
(license license:expat)))
+(define-public ruby-fugit
+ (package
+ (name "ruby-fugit")
+ (version "1.1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "fugit" version))
+ (sha256
+ (base32
+ "1d1ivir1k33kfylyxf6c6g0bn85ia9ls6vv7qps65wfwbxqb8rv0"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; No included tests
+ (propagated-inputs
+ `(("ruby-et-orbi" ,ruby-et-orbi)
+ ("ruby-raabro" ,ruby-raabro)))
+ (synopsis
+ "Time tools for flor and the floraison project. Cron parsing and occurrence computing. Timestamps and more.")
+ (description
+ "Time tools for flor and the floraison project. Cron parsing and occurrence computing. Timestamps and more.")
+ (home-page "http://github.com/floraison/fugit")
+ (license license:expat)))
+
(define-public ruby-fuubar
(package
(name "ruby-fuubar")