summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-30 02:29:43 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-30 03:46:20 +0200
commite02a9975b8d8cc444c6b76483365cc4e2b8d76f9 (patch)
tree2e6a3175213cf85965650e7ffbd8c436767fbd47
parentd67a7e9e8d0595ac8594311e0fb438f476f5d080 (diff)
downloadgnu-guix-e02a9975b8d8cc444c6b76483365cc4e2b8d76f9.tar
gnu-guix-e02a9975b8d8cc444c6b76483365cc4e2b8d76f9.tar.gz
gnu: superlu-dist: Return #t from all phases.
* gnu/packages/maths.scm (superlu-dist)[arguments]: Return #t rather than undefined from phases. Substitute INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/maths.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 140d0bcdf7..cfb4b6f632 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2231,11 +2231,11 @@ CDEFS = -DAdd_"
;; isn't used anyway.)
(setenv "OMPI_MCA_plm_rsh_agent" (which "cat"))
(with-directory-excursion "EXAMPLE"
- (and
- (zero? (system* "mpirun" "-n" "2"
- "./pddrive" "-r" "1" "-c" "2" "g20.rua"))
- (zero? (system* "mpirun" "-n" "2"
- "./pzdrive" "-r" "1" "-c" "2" "cg20.cua"))))))
+ (invoke "mpirun" "-n" "2"
+ "./pddrive" "-r" "1" "-c" "2" "g20.rua")
+ (invoke "mpirun" "-n" "2"
+ "./pzdrive" "-r" "1" "-c" "2" "cg20.cua"))
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
;; Library is placed in lib during the build phase. Copy over