summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-18 22:19:16 +0000
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2020-03-31 21:41:50 +0100
commitddee716c67a514e43444cbf7762c462a880b16c3 (patch)
treec07eeae78994200873bc5cd1a75cd99eb58a1cda
parent107e1ee676ad2e3b18b535f659ce5641ee5339c5 (diff)
downloadgnu-guix-ddee716c67a514e43444cbf7762c462a880b16c3.tar
gnu-guix-ddee716c67a514e43444cbf7762c462a880b16c3.tar.gz
gnu: Add ruby-annotate.
-rw-r--r--gnu/packages/rails.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
index f77c153197..2f9cfcd301 100644
--- a/gnu/packages/rails.scm
+++ b/gnu/packages/rails.scm
@@ -124,6 +124,40 @@ API.")
"https://github.com/banister/debug_inspector")
(license license:expat)))
+(define-public ruby-annotate
+ (package
+ (name "ruby-annotate")
+ (version "2.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "annotate" version))
+ (sha256
+ (base32
+ "079y33iy65nv1cqnh1zmi3v2y9yp1z3zzsf2wdh35m3c80v6kaz4"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-annotate
+ (lambda _
+ (substitute* "bin/annotate"
+ (("require 'bundler'")
+ "")
+ (("Bundler.setup")
+ "")))))))
+ (propagated-inputs
+ `(("ruby-activerecord" ,ruby-activerecord)
+ ("ruby-activesupport" ,ruby-activesupport)))
+ (synopsis
+ "Annotates Rails/ActiveRecord Models, routes, fixtures, and others based on the database schema.")
+ (description
+ "Annotates Rails/ActiveRecord Models, routes, fixtures, and others based on the database schema.")
+ (home-page
+ "http://github.com/ctran/annotate_models")
+ (license #f)))
+
(define-public ruby-autoprefixer-rails
(package
(name "ruby-autoprefixer-rails")