summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-27 00:34:46 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-04-27 02:56:43 +0200
commitca2158bb3a0f5de3108a4f81e6733a5309e9af1d (patch)
treeb9d9e99a16956148a734023eddccdf1a90a24cc6
parentd5db813b382e941710771ab937bba45d62527691 (diff)
downloadgnu-guix-ca2158bb3a0f5de3108a4f81e6733a5309e9af1d.tar
gnu-guix-ca2158bb3a0f5de3108a4f81e6733a5309e9af1d.tar.gz
gnu: pcmanfm: Update to 1.3.0.
* gnu/packages/lxde.scm (pcmanfm): Update to 1.3.0. [source]: Remove patch. * gnu/packages/patches/pcmanfm-CVE-2017-8934.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/lxde.scm9
-rw-r--r--gnu/packages/patches/pcmanfm-CVE-2017-8934.patch56
3 files changed, 4 insertions, 62 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 3e093b791b..db1c260da6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -977,7 +977,6 @@ dist_patch_DATA = \
%D%/packages/patches/patchelf-rework-for-arm.patch \
%D%/packages/patches/patchutils-xfail-gendiff-tests.patch \
%D%/packages/patches/patch-hurd-path-max.patch \
- %D%/packages/patches/pcmanfm-CVE-2017-8934.patch \
%D%/packages/patches/pcre2-CVE-2017-7186.patch \
%D%/packages/patches/pcre2-CVE-2017-8786.patch \
%D%/packages/patches/perl-file-path-CVE-2017-6512.patch \
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 97ab8720d6..67e66f8f6b 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -205,26 +205,25 @@ speed up the access to freedesktop.org defined application menus.")
(define-public pcmanfm
(package
(name "pcmanfm")
- (version "1.2.5")
+ (version "1.3.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/" name "/"
"PCManFM%20%2B%20Libfm%20%28tarball%20release"
"%29/PCManFM/" name "-" version ".tar.xz"))
- (patches (search-patches "pcmanfm-CVE-2017-8934.patch"))
(sha256
(base32
- "0rxdh0dfzc84l85c54blq42gczygq8adhr3l9hqzy1dp530cm1hc"))))
+ "1ywgfyklms5hqkapsbjps4kyx20ac0d1qk16ww74yagkyfdkwsas"))))
(build-system gnu-build-system)
(inputs `(("gtk+" ,gtk+-2)
- ("gvfs" ,gvfs) ;for trash and mount support
+ ("gvfs" ,gvfs) ; for trash and mount support
("libfm" ,libfm)
("libx11" ,libx11)))
(native-inputs `(("intltool" ,intltool)
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(propagated-inputs
- `(("lxmenu-data" ,lxmenu-data))) ;for "Open With..." application list
+ `(("lxmenu-data" ,lxmenu-data))) ; for "Open With..." application list
(synopsis "LXDE file manager")
(description "PCMan is a lightweight GTK+ based file manager, compliant
with freedesktop.org standard.")
diff --git a/gnu/packages/patches/pcmanfm-CVE-2017-8934.patch b/gnu/packages/patches/pcmanfm-CVE-2017-8934.patch
deleted file mode 100644
index 489d22c83b..0000000000
--- a/gnu/packages/patches/pcmanfm-CVE-2017-8934.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From bc8c3d871e9ecc67c47ff002b68cf049793faf08 Mon Sep 17 00:00:00 2001
-From: Andriy Grytsenko <andrej@rep.kiev.ua>
-Date: Sun, 14 May 2017 21:35:40 +0300
-Subject: [PATCH] Fix potential access violation, use runtime user dir instead
- of tmp dir.
-
----
- NEWS | 4 ++++
- src/single-inst.c | 7 ++++++-
- 2 files changed, 10 insertions(+), 1 deletion(-)
-
-diff --git a/NEWS b/NEWS
-index 8c2049a..876f7f3 100644
---- a/NEWS
-+++ b/NEWS
-@@ -1,3 +1,7 @@
-+* Fixed potential access violation, use runtime user dir instead of tmp dir
-+ for single instance socket.
-+
-+
- Changes on 1.2.5 since 1.2.4:
-
- * Removed options to Cut, Remove and Rename from context menu on mounted
-diff --git a/src/single-inst.c b/src/single-inst.c
-index 62c37b3..aaf84ab 100644
---- a/src/single-inst.c
-+++ b/src/single-inst.c
-@@ -2,7 +2,7 @@
- * single-inst.c: simple IPC mechanism for single instance app
- *
- * Copyright 2010 Hong Jen Yee (PCMan) <pcman.tw@gmail.com>
-- * Copyright 2012 Andriy Grytsenko (LStranger) <andrej@rep.kiev.ua>
-+ * Copyright 2012-2017 Andriy Grytsenko (LStranger) <andrej@rep.kiev.ua>
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
-@@ -404,11 +404,16 @@ static void get_socket_name(SingleInstData* data, char* buf, int len)
- }
- else
- dpynum = 0;
-+#if GLIB_CHECK_VERSION(2, 28, 0)
-+ g_snprintf(buf, len, "%s/%s-socket-%s-%d", g_get_user_runtime_dir(),
-+ data->prog_name, host ? host : "", dpynum);
-+#else
- g_snprintf(buf, len, "%s/.%s-socket-%s-%d-%s",
- g_get_tmp_dir(),
- data->prog_name,
- host ? host : "",
- dpynum,
- g_get_user_name());
-+#endif
- }
-
---
-2.1.4
-