summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-08-15 16:22:11 +0200
committerLudovic Courtès <ludo@gnu.org>2014-08-15 16:26:28 +0200
commitb9b8607824448cd6bd152ca0ede460a7f44f3b2b (patch)
tree712ba5198db83298d6dbf5a65d54189ccfbcae87
parentc0b9213dbbf2d54c58e8fb62a52efc98f184d859 (diff)
downloadgnu-guix-b9b8607824448cd6bd152ca0ede460a7f44f3b2b.tar
gnu-guix-b9b8607824448cd6bd152ca0ede460a7f44f3b2b.tar.gz
Add (guix monad-repl).
* guix/monad-repl.scm: New file. * guix.scm: Add it. * Makefile.am (MODULES): Add it. * doc/guix.texi (The Store Monad): Document it.
-rw-r--r--Makefile.am1
-rw-r--r--doc/guix.texi27
-rw-r--r--guix.scm1
-rw-r--r--guix/monad-repl.scm81
4 files changed, 110 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index eab126acee..17a676ac54 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,6 +37,7 @@ MODULES = \
guix/download.scm \
guix/git-download.scm \
guix/monads.scm \
+ guix/monad-repl.scm \
guix/gexp.scm \
guix/profiles.scm \
guix/serialization.scm \
diff --git a/doc/guix.texi b/doc/guix.texi
index a4ffa8524b..92eccad118 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -1937,6 +1937,33 @@ effect, one must use @code{run-with-store}:
@result{} /gnu/store/...-profile.sh
@end example
+Note that the @code{(guix monad-repl)} module extends Guile's REPL with
+new ``meta-commands'' to make it easier to deal with monadic procedures:
+@code{run-in-store}, and @code{enter-store-monad}. The former, is used
+to ``run'' a single monadic value through the store:
+
+@example
+scheme@@(guile-user)> ,run-in-store (package->derivation hello)
+$1 = #<derivation /gnu/store/@dots{}-hello-2.9.drv => @dots{}>
+@end example
+
+The latter enters a recursive REPL, where all the return values are
+automatically run through the store:
+
+@example
+scheme@@(guile-user)> ,enter-store-monad
+store-monad@@(guile-user) [1]> (package->derivation hello)
+$2 = #<derivation /gnu/store/@dots{}-hello-2.9.drv => @dots{}>
+store-monad@@(guile-user) [1]> (text-file "foo" "Hello!")
+$3 = "/gnu/store/@dots{}-foo"
+store-monad@@(guile-user) [1]> ,q
+scheme@@(guile-user)>
+@end example
+
+@noindent
+Note that non-monadic values cannot be returned in the
+@code{store-monad} REPL.
+
The main syntactic forms to deal with monads in general are described
below.
diff --git a/guix.scm b/guix.scm
index 706ea29065..8753c21e42 100644
--- a/guix.scm
+++ b/guix.scm
@@ -30,6 +30,7 @@
ftp-client
gexp
monads
+ monad-repl
packages
store
utils))
diff --git a/guix/monad-repl.scm b/guix/monad-repl.scm
new file mode 100644
index 0000000000..5242f5448b
--- /dev/null
+++ b/guix/monad-repl.scm
@@ -0,0 +1,81 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix monad-repl)
+ #:use-module (guix store)
+ #:use-module (guix monads)
+ #:use-module (ice-9 pretty-print)
+ #:use-module (system repl repl)
+ #:use-module (system repl common)
+ #:use-module (system repl command)
+ #:use-module (system base language)
+ #:use-module (system base compile)
+ #:use-module (srfi srfi-26)
+ #:export (run-in-store
+ enter-store-monad))
+
+;;; Comment:
+;;;
+;;; This modules provides a couple of REPL meta-commands that make it easier
+;;; to work with monadic procedures in the store monad.
+;;;
+;;; Code:
+
+(define* (monad-language monad run #:optional (name 'monad))
+ "Return a language with a special evaluator that causes monadic values
+ to be \"run\" in MONAD using procedure RUN."
+ (let ((scheme (lookup-language 'scheme)))
+ (define (evaluate-monadic-expression exp env)
+ (let ((mvalue (compile exp #:to 'value #:env env)))
+ (run mvalue)))
+
+ (make-language #:name name
+ #:title "Monad"
+ #:reader (language-reader scheme)
+ #:compilers (language-compilers scheme)
+ #:decompilers (language-decompilers scheme)
+ #:evaluator evaluate-monadic-expression
+ #:printer (language-printer scheme)
+ #:make-default-environment
+ (language-make-default-environment scheme))))
+
+(define (store-monad-language)
+ "Return a compiler language for the store monad."
+ (let ((store (open-connection)))
+ (monad-language %store-monad
+ (cut run-with-store store <>)
+ 'store-monad)))
+
+(define-meta-command ((run-in-store guix) repl (form))
+ "run-in-store EXP
+Run EXP through the store monad."
+ (let ((value (with-store store
+ (run-with-store store (repl-eval repl form)))))
+ (run-hook before-print-hook value)
+ (pretty-print value)))
+
+(define-meta-command ((enter-store-monad guix) repl)
+ "enter-store-monad
+Enter a REPL for values in the store monad."
+ (let ((new (make-repl (store-monad-language))))
+ ;; Force interpretation so that our specially-crafted language evaluator
+ ;; is actually used.
+ (repl-option-set! new 'interp #t)
+ (run-repl new)))
+
+;;; monad-repl.scm ends here