summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-03-17 13:15:33 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-06-16 13:17:50 +0200
commitab621bf142d2803e4a6b8c79df715d204e0bfb47 (patch)
tree7828319bccbf560face0823ba7ecf7f5b8f67cb2
parent7d65489ffe27276d9d373374190bbeedd8a9c6da (diff)
downloadgnu-guix-ab621bf142d2803e4a6b8c79df715d204e0bfb47.tar
gnu-guix-ab621bf142d2803e4a6b8c79df715d204e0bfb47.tar.gz
gnu: Add java-qdox.
* gnu/packages/java.scm (java-qdox): New variable.
-rw-r--r--gnu/packages/java.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 115b0b498b..b4b1eedd2e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -10186,3 +10186,32 @@ This module can be assimilated to a significantly improved version of log4j.
Moreover, @code{logback-classic} natively implements the slf4j API so that you
can readily switch back and forth between logback and other logging frameworks
such as log4j or @code{java.util.logging} (JUL).")))
+
+(define-public java-qdox
+ (package
+ (name "java-qdox")
+ ; Newer version exists, but this version is required by java-plexus-component-metadata
+ (version "2.0-M2")
+ (source (origin
+ (method url-fetch)
+ ;; 2.0-M4, -M5 at https://github.com/paul-hammant/qdox
+ ;; Older releases at https://github.com/codehaus/qdox/
+ ;; Note: The release at maven is pre-generated. The release at
+ ;; github requires jflex.
+ (uri (string-append "http://central.maven.org/maven2/"
+ "com/thoughtworks/qdox/qdox/" version
+ "/qdox-" version "-sources.jar"))
+ (sha256
+ (base32
+ "10xxrcaicq6axszcr2jpygisa4ch4sinyx5q7kqqxv4lknrmxp5x"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "qdox.jar"
+ #:tests? #f)); no tests
+ (home-page "http://qdox.codehaus.org/")
+ (synopsis "Parse definitions from Java source files")
+ (description "QDox is a high speed, small footprint parser for extracting
+class/interface/method definitions from source files complete with JavaDoc
+@code{@@tags}. It is designed to be used by active code generators or
+documentation tools.")
+ (license license:asl2.0)))