summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-06 17:14:53 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-06 17:33:58 +0100
commita24fda8114eb49595adb6f08bdb44da0a135e0cd (patch)
tree0e77f002723f9be6e13f91d095d5ec1fdd1b700f
parent5f0f368630ba4c69e902aeab64edeb3d9f94b9b5 (diff)
downloadgnu-guix-a24fda8114eb49595adb6f08bdb44da0a135e0cd.tar
gnu-guix-a24fda8114eb49595adb6f08bdb44da0a135e0cd.tar.gz
gnu: bdb: Correct license.
* gnu/packages/databases.scm (bdb)[license]: Replace with up-to-date information. Move previous contents to ... (bdb-5.3)[license]: ... here.
-rw-r--r--gnu/packages/databases.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 38fcaa1e6d..8972c283de 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -65,7 +65,7 @@
#:use-module (gnu packages jemalloc)
#:use-module ((guix licenses)
#:select (gpl2 gpl3 gpl3+ lgpl2.1+ lgpl3+ x11-style non-copyleft
- bsd-2 bsd-3 public-domain asl2.0))
+ agpl3+ bsd-2 bsd-3 public-domain asl2.0))
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -194,8 +194,9 @@ and provides interfaces to the traditional file format.")
(description
"Berkeley DB is an embeddable database allowing developers the choice of
SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
- (license (non-copyleft "file://LICENSE"
- "See LICENSE in the distribution."))
+ ;; Starting with version 6, BDB is distributed under AGPL3. Many individual
+ ;; files are covered by the 3-clause BSD license.
+ (license (list agpl3+ bsd-3))
(home-page
"http://www.oracle.com/us/products/database/berkeley-db/overview/index.html")))
@@ -203,6 +204,8 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
(package (inherit bdb)
(name "bdb")
(version "5.3.28")
+ (license (non-copyleft "file://LICENSE"
+ "See LICENSE in the distribution."))
(source (origin
(method url-fetch)
(uri (string-append "http://download.oracle.com/berkeley-db/db-"