summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-09-22 20:14:35 +0100
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2017-09-23 20:17:07 +0100
commit78ae416d0f3cfe199ef217f549619a01f4ffb00a (patch)
treecb02cd7cd60c0bbe5f79d80cae32f13b72095a2b
parentd6b4936d20b08f8894975f26dc9dcaa314ccb64e (diff)
downloadgnu-guix-78ae416d0f3cfe199ef217f549619a01f4ffb00a.tar
gnu-guix-78ae416d0f3cfe199ef217f549619a01f4ffb00a.tar.gz
gnu: Add ruby-multi-json.
* gnu/packages/ruby.scm (ruby-multi-json): New variable.
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ff6be875fb..116db8c624 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1865,6 +1865,30 @@ net/http library.")
(home-page "https://github.com/nicksieger/multipart-post")
(license license:expat)))
+(define-public ruby-multi-json
+ (package
+ (name "ruby-multi-json")
+ (version "1.12.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "multi_json" version))
+ (sha256
+ (base32
+ "1raim9ddjh672m32psaa9niw67ywzjbxbdb8iijx3wv9k5b0pk2x"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ;; No testsuite.
+ (synopsis
+ "Common interface to multiple JSON libraries for Ruby")
+ (description
+ "This package provides a common interface to multiple JSON libraries,
+including Oj, Yajl, the JSON gem (with C-extensions), the pure-Ruby JSON gem,
+NSJSONSerialization, gson.rb, JrJackson, and OkJson.")
+ (home-page
+ "http://github.com/intridea/multi_json")
+ (license license:expat)))
+
(define-public ruby-arel
(package
(name "ruby-arel")