summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-06 12:54:57 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-06 14:22:16 +0100
commit5f0f368630ba4c69e902aeab64edeb3d9f94b9b5 (patch)
tree0b5c0032aff36e5959a3593b3a0790c9079eacc7
parentd846834fc2b2f76aa2e258685bc211edd31866c5 (diff)
downloadgnu-guix-5f0f368630ba4c69e902aeab64edeb3d9f94b9b5.tar
gnu-guix-5f0f368630ba4c69e902aeab64edeb3d9f94b9b5.tar.gz
gnu: dosfstools: Update to 4.1.
* gnu/packages/disk.scm (dosfstools): Update to 4.1. [arguments]: Enable tests. [native-inputs]: Add VIM.
-rw-r--r--gnu/packages/disk.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 90e68c2916..4cf9607a43 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,6 +45,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages guile)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages vim)
#:use-module (gnu packages xml))
(define-public parted
@@ -177,7 +178,7 @@ to recover data more efficiently by only reading the necessary blocks.")
(define-public dosfstools
(package
(name "dosfstools")
- (version "4.0")
+ (version "4.1")
(source
(origin
(method url-fetch)
@@ -186,12 +187,13 @@ to recover data more efficiently by only reading the necessary blocks.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1bvxbv1w6vhbx0nx7ygp700wq5k2hjv0hm7w0kz1x7amaf4p6dwh"))))
+ "0wy13i3i4x2bw1hf5m4fd0myh61f9bcrs035fdlf6gyc1jksrcp6"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list (string-append "PREFIX=" %output)
- "CC=gcc")
- #:tests? #f)) ;no tests
+ "CC=gcc")))
+ (native-inputs
+ `(("xxd" ,vim))) ; for tests
(home-page "https://github.com/dosfstools/dosfstools")
(synopsis "Utilities for making and checking MS-DOS FAT file systems")
(description