summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-07-01 15:23:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-07-01 15:23:11 +0200
commit545ceac801404f7ff3501b9f47cdc4e383592656 (patch)
treee2319b8d7caeb8aa72cd068f636a52efcf9e342a
parentdfee30c7eab17412bf579ab5cb00c8c6900bfd62 (diff)
downloadgnu-guix-545ceac801404f7ff3501b9f47cdc4e383592656.tar
gnu-guix-545ceac801404f7ff3501b9f47cdc4e383592656.tar.gz
gnu: musescore: Update to 2.3.
* gnu/packages/music.scm (musescore): Update to 2.3. [source]: Switch to a more stable location. [arguments]: Remove a fix applied upstream.
-rw-r--r--gnu/packages/music.scm26
1 files changed, 9 insertions, 17 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5d97482513..deb4f222b8 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3513,16 +3513,16 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
(define-public musescore
(package
(name "musescore")
- (version "2.2.1")
+ (version "2.3")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/musescore/MuseScore/archive/"
- "v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/musescore/MuseScore.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1ml99ayzpdyd18cypcp0lbsbasfg3abw57i5fl7ph5739vikj6i6"))
+ "1y5x0a40x7ji4g4181adm95qxk2dfjiy5xb5wksps90ji9q2qlcs"))
(modules '((guix build utils)))
(snippet
;; Un-bundle OpenSSL and remove unused libraries.
@@ -3543,8 +3543,8 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
`(,(string-append "PREFIX=" (assoc-ref %outputs "out"))
"USE_SYSTEM_FREETYPE=ON"
"DOWNLOAD_SOUNDFONT=OFF"
- ;; The following is not supported since Qt 5.11. Can be
- ;; removed in Musescore 2.2.2+.
+ ;; The following is not supported since Qt 5.11. May be removed in
+ ;; a future release.
"BUILD_WEBKIT=OFF")
;; There are tests, but no simple target to run. The command
;; used to run them is:
@@ -3557,14 +3557,6 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
#:tests? #f
#:phases
(modify-phases %standard-phases
- ;; Fix Qt 5.11 upgrade. Should be fixed in 2.2.2+, see:
- ;; <https://github.com/musescore/MuseScore/commit/d10e70415c8e52e2ba9d45de564467e42f66c102>
- (add-after 'unpack 'patch-sources
- (lambda _
- (substitute* "all.h"
- (("#include <QRadioButton>") "#include <QRadioButton>
-#include <QButtonGroup>"))
- #t))
(delete 'configure))))
(inputs
`(("alsa-lib" ,alsa-lib)