summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-10 23:41:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-10 23:42:54 +0100
commit4cbbb16045d930b074268e9bc72922578ce31059 (patch)
treebbe6072d111445e012cc1b7a5b15bc7feac65bd2
parentf116e1fcae18d07c116d5d96bdb4de20cd783b5f (diff)
downloadgnu-guix-4cbbb16045d930b074268e9bc72922578ce31059.tar
gnu-guix-4cbbb16045d930b074268e9bc72922578ce31059.tar.gz
gnu: nxbelld: Remove custom bootstrap phase.
* gnu/packages/xdisorg.scm (nxbelld)[arguments]: Remove autoreconf phase.
-rw-r--r--gnu/packages/xdisorg.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index cf3e33eb5b..c54282b985 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2015 xd1le <elisp.vim@gmail.com>
;;; Copyright © 2015 Florian Paul Schmidt <mista.tapas@gmx.net>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
-;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
@@ -1338,15 +1338,11 @@ invert colors on a specific display/screen.")
(build-system gnu-build-system)
(arguments '(#:configure-flags `("--enable-sound"
"--enable-wave"
- "--enable-alsa")
- #:phases (modify-phases %standard-phases
- (add-before 'configure 'autoreconf
- (lambda _
- (invoke "autoreconf" "-vfi"))))))
- (native-inputs `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)
- ("perl" ,perl)))
+ "--enable-alsa")))
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("perl" ,perl)))
(inputs `(("libx11" ,libx11)
("alsa-lib" ,alsa-lib)))
(synopsis "Daemon that performs an action every time the X11 bell is rung")