summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-11-22 11:26:02 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-22 22:59:31 +0100
commit10da75dff8cac41658b6a2eaf8cfeae691242a28 (patch)
tree6319889514bb931e4485d0980aadaa95784c997e
parent8957af324be5014c433cb7d0e18fc2d35ce8cf4b (diff)
downloadgnu-guix-10da75dff8cac41658b6a2eaf8cfeae691242a28.tar
gnu-guix-10da75dff8cac41658b6a2eaf8cfeae691242a28.tar.gz
gnu: grub: Add dependency on LVM2.
* gnu/packages/grub.scm (grub)[inputs]: Add LVM2.
-rw-r--r--gnu/packages/grub.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/grub.scm b/gnu/packages/grub.scm
index b920be9ea2..ef7395e95e 100644
--- a/gnu/packages/grub.scm
+++ b/gnu/packages/grub.scm
@@ -127,9 +127,16 @@
(("set -e") "exit 77\nset -e"))
#t)))))
(inputs
- `(;; ("lvm2" ,lvm2)
- ("gettext" ,gettext-minimal)
+ `(("gettext" ,gettext-minimal)
+
+ ;; Depend on LVM2 for libdevmapper, used by 'grub-probe' and
+ ;; 'grub-install' to recognize mapped devices (LUKS, etc.)
+ ("lvm2" ,lvm2)
+
+ ;; Depend on mdadm, which is invoked by 'grub-probe' and 'grub-install'
+ ;; to determine whether the root file system is RAID.
("mdadm" ,mdadm)
+
("freetype" ,freetype)
;; ("libusb" ,libusb)
;; ("fuse" ,fuse)