summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-01 16:36:27 +0000
committerMarius Bakke <mbakke@fastmail.com>2017-05-25 20:15:39 +0200
commit103b7e7955a06b61f570ebede3bf2039f0f847ab (patch)
tree4e7d1a3c5e1f67ac71ce4bbc97911a8d19b8a8ca
parentfd7000fe33d3c4188c241cab97e2b891dd4e1268 (diff)
downloadgnu-guix-103b7e7955a06b61f570ebede3bf2039f0f847ab.tar
gnu-guix-103b7e7955a06b61f570ebede3bf2039f0f847ab.tar.gz
gnu: Add kbd-neo.
* gnu/packages/linux.scm (kbd-neo): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/linux.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d6ffa95ca5..2e984dd421 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1641,6 +1641,38 @@ system.")
(license (list license:gpl2 ;programs
license:lgpl2.1)))) ;library
+(define-public kbd-neo
+ (package
+ (name "kbd-neo")
+ (version "2486")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://svn.neo-layout.org/!svn/bc/"
+ version "/linux/console/neo.map"))
+ (file-name (string-append name "-" version ".map"))
+ (sha256
+ (base32
+ "19mfrd31vzpsjiwc7pshxm0b0sz5dd17xrz6k079cy4im1vf0r4g"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (let ((out (string-append %output "/share/keymaps"))
+ (source (assoc-ref %build-inputs "source")))
+ (mkdir-p out)
+ (copy-file source (string-append out "/neo.map"))
+ #t))))
+ (home-page "https://neo-layout.org")
+ (synopsis "Neo2 console layout")
+ (description
+ "Kbd-neo provides the Neo2 keyboard layout for use with
+@command{loadkeys(1)} from @code{kbd(4)}.")
+ ;; The file is located in an svn directory, the entire content of
+ ;; the directory is licensed as GPL3.
+ (license license:gpl3+)))
+
(define-public kbd
(package
(name "kbd")