summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-02-17 17:12:56 +0000
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2019-02-24 16:28:09 +0000
commit180e7ccb271ebe8580b991720d8c2661f5355d1c (patch)
tree9ae00b1c9a48134e40713feaf8682288ab23f1f3
parent39d72c37a2d484b8a30a4e5ba23a05baa9656e9c (diff)
downloadgnu-guix-180e7ccb271ebe8580b991720d8c2661f5355d1c.tar
gnu-guix-180e7ccb271ebe8580b991720d8c2661f5355d1c.tar.gz
gnu: Add ruby-omniauth.
* gnu/packags/ruby.scm (ruby-omniauth): New variable.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0cd3b32d4c..55f2520156 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1202,6 +1202,31 @@ with a similar style to the original OAuth spec.")
(home-page "https://github.com/oauth-xx/oauth2")
(license license:expat)))
+(define-public ruby-omniauth
+ (package
+ (name "ruby-omniauth")
+ (version "1.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "omniauth" version))
+ (sha256
+ (base32
+ "1p16h1rp8by05k8gfw17xjhgwp60dk8qmj1xalv1n23kmxfsxb1x"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(;; No incldued tests
+ #:tests? #f))
+ (propagated-inputs
+ `(("ruby-hashie" ,ruby-hashie)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis "Generalized Rack framework for multiple-provider authentication")
+ (description
+ "This package provides a generalized Rack framework for multiple-provider
+authentication.")
+ (home-page "https://github.com/omniauth/omniauth")
+ (license license:expat)))
+
(define-public ruby-open4
(package
(name "ruby-open4")