summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:56:01 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:46:23 +0000
commitf4820ed699c0c8ebb1036d5f891dc330a1907e36 (patch)
treee38d224dab652a3ef298f6fc9be31160c16f62c9
parent1f8664eb0539c62a77ac61bfec4aa34640937242 (diff)
downloadgnu-guix-f4820ed699c0c8ebb1036d5f891dc330a1907e36.tar
gnu-guix-f4820ed699c0c8ebb1036d5f891dc330a1907e36.tar.gz
gnu: Add ruby-rr.
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e515d749f9..b63517de59 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4620,6 +4620,30 @@ clickjacking, directory traversal, session hijacking and IP spoofing.")
(home-page "")
(license license:expat)))) ;?
+(define-public ruby-rr
+ (package
+ (name "ruby-rr")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rr" version))
+ (sha256
+ (base32
+ "0b05ycaw17wbxzycv1wvzklpqjnmi0dqy01igcl5jfmy1ydky66r"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; test files not included
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (synopsis
+ "RR is a test double framework that features a rich selection of double techniques and a terse syntax.")
+ (description
+ "RR is a test double framework that features a rich selection of double techniques and a terse syntax.")
+ (home-page "https://rr.github.io/rr")
+ (license license:expat)))
+
(define-public ruby-rubocop
(package
(name "ruby-rubocop")