summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2018-09-03 02:25:31 +0800
committerLudovic Courtès <ludo@gnu.org>2018-09-04 15:39:43 +0200
commit1bf758767d1553594b6d7534ca8c38a2171b5afe (patch)
treea2008c91c83eddb9095b1b058a195e897973bb05
parent71ca16b58d20aa26157acc4c345c0af80ec8df5d (diff)
downloadgnu-guix-1bf758767d1553594b6d7534ca8c38a2171b5afe.tar
gnu-guix-1bf758767d1553594b6d7534ca8c38a2171b5afe.tar.gz
gnu: Add emacs-picpocket.
* gnu/packages/emacs.scm (emacs-picpocket): New public variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 8f0c564f88..957b72f4e7 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2017, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2016, 2017 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2017, 2018 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -11315,6 +11315,43 @@ e.g. the package dependencies it requires. See function
file.")
(license license:gpl3+))))
+(define-public emacs-picpocket
+ (let ((version "20180610.1059") ; taken from melpa
+ (commit "ce4b6ed088384f2414af82e8e4eae5b92c2874bf"))
+ (package
+ (name "emacs-picpocket")
+ (version version)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/johanclaesson/picpocket")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15vpbcv83mc4j1pvrk7xic0klh2bl9gzg2xxs7c2lmnix52hy8mv"))))
+ (build-system emacs-build-system)
+ (arguments ; needed for running tests
+ `(#:tests? #t
+ #:emacs ,emacs
+ #:test-command '("emacs" "--batch"
+ "-l" "picpocket-test.el"
+ "-f" "ert-run-tests-batch-and-exit")))
+ (home-page "https://github.com/johanclaesson/picpocket")
+ (synopsis "Image viewer for Emacs")
+ (description
+ "Picpocket is an image viewer for GNU Emacs. It has commands for:
+
+@itemize
+@item File operations on the picture files (delete, move, copy, hardlink).
+@item Scale and rotate the picture.
+@item Associate pictures with tags which are saved to disk.
+@item Filter pictures according to tags.
+@item Customizing keystrokes for quick tagging and file operations.
+@item Undo and browse history of undoable commands.
+@end itemize")
+ (license license:gpl3+))))
+
(define-public emacs-wgrep-helm
;; `emacs-wgrep-helm' was mistakenly added.
(deprecated-package "emacs-wgrep-helm" emacs-wgrep))